CÔNG TY CỔ PHẦN DỊCH VỤ CÔNG NGHỆ DATECH

Số 23E4 KĐT Cầu Diễn, Tổ 7, Phú Diễn, Bắc Từ Liêm, Hà Nội


Hướng dẫn cấu hình Load Balancing nhiều WAN trên Router Cisco

Hướng dẫn cấu hình Load Balancing nhiều WAN trên Router Cisco

Bài viết hướng dẫn này giúp các bạn cấu hình FTTH - PPPoE load balancing / failover giữa 2 kết nối WAN trên 1 thiết bị router Cisco. Ngoài ra, hướng dẫn này cũng giúp bạn biết cách public 1 dịch vụ từ mạng LAN ra ngoài Internet trên cả 2 kết nối WAN này.

- Để cấu hình FTTH - PPPoE trên các thiết bị router Cisco, chúng ta cần chuẩn bị các thông tin sau:
- Username và password của line WAN do nhà mạng cung cấp.
- Ngoài ra, để public dịch vụ ra Internet, thông thường chúng ta phải có IP WAN tĩnh. Theo mô hình này IP WAN tĩnh của 2 nhà mạng cấp cho chúng ta là:

  • ISP1: 118.69.53.32
  • ISP2: 112.213.89.79

Các bước thực hiện:
- Định nghĩa Interface LAN
- Định nghĩa Interface WAN
- Định nghĩa Dialer Interface, dùng để kết nối PPPoE đến 2 nhà mạng.
- Định nghĩa NAT để người dùng trong mạng LAN có thể truy cập Internet trên 2 kết nối WAN
- Định nghĩa các track của 2 WAN trạng thái up và down của 2 WAN để định tuyến dữ liệu từ LAN ra WAN.
- Định nghĩa IP routing
- Định nghĩa static NAT để public dịch vụ Web trong mạng LAN ra ngoài Internet thông qua 2 kết nối WAN

Sau đây là các bước thực hiện tuần tự:

Cấu hình Interface LAN:
Router(config)# interface GigabitEthernet0/0
Router(config-if)#description #LAN Interface#
Router(config-if)#ip address 192.168.1.1
Router(config-if)#no shutdown
Router(config-if)#ip nat inside

Cấu hình Interface WAN 1:
Router(config)# interface GigabitEthernet0/1
Router(config-if)#description #WAN Interface to ISP1#
Router(config-if)#no ip address
Router(config-if)#pppoe enable group global
Router(config-if)#pppoe-client dial-pool-number 1
Router(config-if)#no shutdown

Cấu hình Interface WAN 2:
Router(config)# interface GigabitEthernet0/2
Router(config-if)#description #WAN Interface to ISP2#
Router(config-if)#no ip address
Router(config-if)#pppoe enable group global
Router(config-if)#pppoe-client dial-pool-number 2
Router(config-if)#no shutdown

Cấu hình dịch vụ dialer để quay số PPoE:
Router(config)# interface dialer 1
Router(config-if)#description #Dialer interface to ISP 1#
Router(config-if)#ip mtu 1492
Router(config-if)# dialer pool 1
Router(config-if)# encapsulation ppp
Router(config-if)# ip address negotiated
Router(config-if)#ip nat outside
Router(config-if)#ppp pap sent-username ftth_myUsername_ISP1 password 0 ftth_myPassword_ISP1

Router(config)# interface dialer 2
Router(config-if)#description #Dialer interface to ISP 2#
Router(config-if)#ip mtu 1492
Router(config-if)# dialer pool 2
Router(config-if)# encapsulation ppp
Router(config-if)# ip address negotiated
Router(config-if)#ip nat outside
Router(config-if)#ppp pap sent-username ftth_myUsername_ISP2 password 0 ftth_myPassword_ISP2

Cấu hình ACL và NAT:
Router(config)#access-list 100 permit ip 192.168.1.0 0.0.0.255 any

Router(config)#route-map isp1 permit 10
Router(config-route-map)#match ip address 100
Router(config-router-map)#match interface Dialer 1

Router(config)#route-map isp2 permit 20
Router(config-route-map)#match ip address 100
Router(config-router-map)#match interface Dialer 2

Router(config)#ip nat inside source route-map isp1 interface Dialer 1 overload
Router(config)#ip nat inside source route-map isp2 interface Dialer 2 overload

Tạo Tracking-Object cho Dialer 1:
Router(config)#ip sla monitor 100
Router(config-sla-monitor)#type echo protocol ipIcmpEcho 8.8.8.8 source-interface Dialer 1
Router(config-sla-monitor)#timeout 500
Router(config-sla-monitor)#frequency 3
!!! Tracking-Object ping Google dns 8.8.8.8 qua interface Dialer 1 mỗi 3 giây và timeout sau 500ms không nhận được response.

Lâp lịch cho Tracking-Object thực thi tức thì và liên tục:
Router(config)#ip sla monitor schedule 100 life forever start-time now

Track đối tượng Tracking-Object ở trên:
Router(config)#track 100 rtr 100 reachability
Router(config-track)#delay down 10 up 20

Tạo Tracking-Object cho Dialer 2
Router(config)#ip sla monitor 200
Router(config-sla-monitor)#type echo protocol ipIcmpEcho 8.8.8.8 source-interface Dialer 2
Router(config-sla-monitor)#timeout 500
Router(config-sla-monitor)#frequency 3
!!! Tracking-Object ping Google dns 8.8.8.8 qua interface Dialer 2 mỗi 3 giây và timeout sau 500ms không nhận được response.

Lâp lịch cho Tracking-Object thực thi tức thì và liên tục
Router(config)#ip sla monitor schedule 200 life forever start-time now

Track đối tượng Tracking-Object ở trên
Router(config)#track 200 rtr 200 reachability
Router(config-track)#delay down 10 up 20

Router(config)#ip route 0.0.0.0 0.0.0.0 Dialer 1 track 100
Router(config)#ip route 0.0.0.0 0.0.0.0 Dialer 2 track 200

Publish dịch vụ web ra Internet qua 2 WAN IP.
Router(config)#route-map isp1static permit 10
Router(config-route-map)#match interface Dialer 1

Router(config)#route-map isp2static permit 10
Router(config-route-map)#match interface Dialer 2

Router(config)#ip nat inside source static tcp 192.168.1.100 80 118.69.53.32 80 route-map isp1static
Router(config)#ip nat inside source static tcp 192.168.1.100 80 112.213.89.79 80 route-map isp2static

Các lệnh dùng để troubleshooting cấu hinh PPPoE, NAT
Router(config)#show ip interface brief
Router(config)#show ip nat translation
Router(config)#debug ppp authentication

Hi vọng bài viết này sẽ giúp ích cho các bạn trong công việc. Nếu bạn có vấn đề gì thắc mắc đừng ngần ngại liên hệ với chúng tôi theo thông tin dưới đây để được hỗ trợ thêm.

Hẹn gặp lại các bạn trong các bài viết tiếp theo !

CÔNG TY CỔ PHẦN DỊCH VỤ CÔNG NGHỆ DATECH

• Địa chỉ: Số 23E4 KĐT Cầu Diễn, Tổ 7, Phú Diễn, Bắc Từ Liêm, Hà Nội

• Điện thoại: 02432012368

• Hotline: 098 115 6699

• Email: info@datech.vn

• Website: https://datech.vn