CÔNG TY CỔ PHẦN DỊCH VỤ CÔNG NGHỆ DATECH

Số 23E4 KĐT Cầu Diễn, Tổ 7, Phú Diễn, Bắc Từ Liêm, Hà Nội


Hướng dẫn cấu hình lọc route bằng hiệu chỉnh AD (Administrative Distance)

Danh sách nội dung [Ẩn]

Hướng dẫn cấu hình lọc route bằng hiệu chỉnh AD (Administrative Distance)

Trong nhiều trường hợp, người quản trị muốn kiểm soát thông tin định tuyến trao đổi giữa các router. Để làm được điều này, người quản trị cần phải thực hiện các kỹ thuật lọc route cho phép lọc bớt các route trong các bản tin cập nhật mà router sẽ gửi đi hoặc nhận về. Có nhiều kỹ thuật lọc route có thể được triển khai. Trong bài viết này chúng ta sẽ cùng tìm hiểu kỹ thuật lọc route bằng cách hiệu chỉnh giá trị AD của giao thức định tuyến.

Trong bài viết này mình sẽ thực hiện mô hình lab như bên dưới để các bạn hiểu rõ hơn về vấn đề này. Tất cả các thiết bị ở bài ví dụ đều chạy trên IOS của Router Cisco.

Sơ đồ

 

Thực hiện

Bước 1: Cấu hình ban đầu

• Cấu hình đặt địa chỉ IP trên các cổng của các router theo quy hoạch IP được chỉ ra trên hình trên.
• Chạy định tuyến RIPv2 đảm bảo mọi địa chỉ thấy nhau.

Cấu hình

Trên R1:

R1(config)#interface f0/0
R1(config-if)#no shutdown
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#exit
R1(config)#interface f0/1
R1(config-if)#no shutdown
R1(config-if)#ip address 192.168.13.1 255.255.255.0
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 192.168.12.0
R1(config-router)#network 192.168.13.0
R1(config-router)#exit


Trên R2:

R2(config)#interface f0/0
R2(config-if)#no shutdown
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#exit
R2(config)#interface f0/1
R2(config-if)#no shutdown
R2(config-if)#ip address 192.168.24.2 255.255.255.0
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.12.0
R2(config-router)#network 192.168.24.0
R2(config-router)#exit


Trên R3:

R3(config)#interface f0/0
R3(config-if)#no shutdown
R3(config-if)#ip address 192.168.13.3 255.255.255.0
R3(config-if)#exit
R3(config)#interface f0/1
R3(config-if)#no shutdown
R3(config-if)#ip address 192.168.34.3 255.255.255.0
R3(config-if)#exit
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#no auto-summary
R3(config-router)#network 192.168.13.0
R3(config-router)#network 192.168.34.0
R3(config-router)#exit


Trên R4:

R4(config)#interface loopback 0
R4(config-if)#ip address 192.168.4.1 255.255.255.0
R4(config-if)#exit
R4(config)#interface loopback 1
R4(config-if)#ip address 192.168.44.1 255.255.255.0
R4(config-if)#exit
R4(config)#interface f0/0
R4(config-if)#no shutdown
R4(config-if)#ip address 192.168.24.4 255.255.255.0
R4(config-if)#exit
R4(config)#interface f0/1
R4(config-if)#no shutdown
R4(config-if)#ip address 192.168.34.4 255.255.255.0
R4(config-if)#exit
R4(config)#router rip
R4(config-router)#version 2
R4(config-router)#no auto-summary
R4(config-router)#network 192.168.4.0
R4(config-router)#network 192.168.24.0
R4(config-router)#network 192.168.34.0
R4(config-router)#network 192.168.44.0
R4(config-router)#exit


Kiểm tra

Ta kiểm tra rằng định tuyến đã hội tụ trên các router với lệnh show ip route rip :

R1#show ip route rip
R 192.168.44.0/24 [120/2] via 192.168.13.3, 00:00:12, FastEthernet0/1
[120/2] via 192.168.12.2, 00:00:19, FastEthernet0/0
R 192.168.24.0/24 [120/1] via 192.168.12.2, 00:00:19, FastEthernet0/0
R 192.168.4.0/24 [120/2] via 192.168.13.3, 00:00:12, FastEthernet0/1
[120/2] via 192.168.12.2, 00:00:19, FastEthernet0/0
R 192.168.34.0/24 [120/1] via 192.168.13.3, 00:00:12, FastEthernet0/1


R2#show ip route rip
R 192.168.13.0/24 [120/1] via 192.168.12.1, 00:00:25, FastEthernet0/0
R 192.168.44.0/24 [120/1] via 192.168.24.4, 00:00:13, FastEthernet0/1
R 192.168.4.0/24 [120/1] via 192.168.24.4, 00:00:13, FastEthernet0/1
R 192.168.34.0/24 [120/1] via 192.168.24.4, 00:00:13, FastEthernet0/1


R3#show ip route rip
R 192.168.12.0/24 [120/1] via 192.168.13.1, 00:00:13, FastEthernet0/0
R 192.168.44.0/24 [120/1] via 192.168.34.4, 00:00:03, FastEthernet0/1
R 192.168.24.0/24 [120/1] via 192.168.34.4, 00:00:03, FastEthernet0/1
R 192.168.4.0/24 [120/1] via 192.168.34.4, 00:00:03, FastEthernet0/1


R4#show ip route rip
R 192.168.12.0/24 [120/1] via 192.168.24.2, 00:00:09, FastEthernet0/0
R 192.168.13.0/24 [120/1] via 192.168.34.3, 00:00:18, FastEthernet0/1


Bước 2: Lọc route để hiệu chỉnh đường đi

• Cấu hình lọc route trên R1 để hiệu chỉnh đường đi theo yêu cầu sau:

R1 đi đến loopback 0 của R4 theo đường trên (qua R2), không đi đường dưới (qua R3).
R1 đi đến loopback 1 của R4 theo đường dưới (qua R3), không đi đường trên (qua R2).

• Sử dụng phương thức hiệu chỉnh AD trên R1 để thực hiện lọc route.

Cấu hình

Trên R1:

R1(config)#access-list 4 permit 192.168.4.0
R1(config)#access-list 44 permit 192.168.44.0
R1(config)#router rip
R1(config-router)#distance 255 192.168.12.2 0.0.0.0 44
R1(config-router)#distance 255 192.168.13.3 0.0.0.0 4
R1(config-router)#exit


Kiểm tra

Sau khi lọc route, ta kiểm tra rằng R1 chỉ còn giữ lại một đường duy nhất để đi đến các loopback của R4:

R1#show ip route rip
R 192.168.44.0/24 [120/2] via 192.168.13.3, 00:00:00, FastEthernet0/1
R 192.168.24.0/24 [120/1] via 192.168.12.2, 00:00:01, FastEthernet0/0
R 192.168.4.0/24 [120/2] via 192.168.12.2, 00:00:01, FastEthernet0/0
R 192.168.34.0/24 [120/1] via 192.168.13.3, 00:00:00, FastEthernet0/1

Ta kiểm tra rằng R1 đã đi đến các loopback của R4 đúng theo yêu cầu đặt ra.

R1 đi đến loopback 0 của R4 theo đường trên (qua R2):

R1#traceroute 192.168.4.1
Type escape sequence to abort.
Tracing the route to 192.168.4.1
1 192.168.12.2 44 msec 76 msec 24 msec
2 192.168.24.4 88 msec * 108 msec

R1 đi đến loopback 1 của R4 theo đường dưới:

R1#traceroute 192.168.44.1
Type escape sequence to abort.
Tracing the route to 192.168.44.1
1 192.168.13.3 84 msec 40 msec 40 msec
2 192.168.34.4 76 msec * 100 msec

Chúc các bạn thành công. Nếu bạn có vấn đề gì thắc mắc đừng ngần ngại liên hệ với chúng tôi theo thông tin dưới đây để được hỗ trợ thêm.

Hẹn gặp lại các bạn trong các bài viết tiếp theo !

CÔNG TY CỔ PHẦN DỊCH VỤ CÔNG NGHỆ DATECH

• Địa chỉ: Số 23E4 KĐT Cầu Diễn, Tổ 7, Phú Diễn, Bắc Từ Liêm, Hà Nội

• Điện thoại: 02432012368

• Hotline: 098 115 6699

• Email: info@datech.vn

• Website: https://datech.vn