CÔNG TY CỔ PHẦN DỊCH VỤ CÔNG NGHỆ DATECH

Số 23E4 KĐT Cầu Diễn, Tổ 7, Phú Diễn, Bắc Từ Liêm, Hà Nội


Hai cách viết lệnh network trong EIGRP-cơ bản

Hai cách viết lệnh network trong EIGRP-cơ bản

Khi cấu hình lệnh quảng bá dải mạng EIGRP cơ bản cho mô hình dưới

Ta có thể gặp 2 dạng lệnh: ví dụ cấu hình trên R3

Dạng 1: Chỉ rõ wildcard mask

router eigrp 1

network 10.1.3.0  0.0.0.255

network 10.2.3.0  0.0.0.255

no auto-summary

Dạng 2: không cần chỉ ra wildcard

router eigrp 1

network 10.1.3.0 ##Không chỉ ra wildcard mask

no auto-summary

Vậy 2 dạng này khác nhau ở chỗ nào?

=> Khi chỉ ra rõ wildcard mask => thì chỉ cho interface nào có IP thuộc dải đó được chạy eigrp

Ví dụ trên R3 chỉ gõ là:

router eigrp 1

network 10.1.3.0  0.0.0.255 => chỉ cho interface nối sang R1 chạy EIGRP thôi

 Còn khi không chỉ ra wildcard mask thì trong running-config sẽ hiện thành 10.0.0.0 hoặc 172.X.0.0 hoặc 192.168.X.0 .

Ý nghĩa lệnh: sẽ cho tất cả các interface nào có IP thuộc dải 10.0.0.0/8 (theo ví dụ trên) được chạy EIGRP

 Ví dụ trên R1: ta gõ rút gọn như này (không chỉ ra wildcard mask)

router eigrp 1

network 10.1.3.0

network 172.17.1.100

network 192.168.1.100

Thì trong router sẽ hiện như này:

R1#show run | sec eigrp

router eigrp 1

network 10.0.0.0

network 172.17.0.0

network 192.168.1.0

Vậy khi muốn cho tất cả các interface chạy EIGRP thì ta có thể viết gọn như dạng 2, còn khi chỉ muốn 1 số interface nào đó chạy EIGRP thì dùng wildcard mask như dạng 1

Hi vọng bài viết này sẽ giúp ích cho các bạn trong công việc. Nếu bạn có vấn đề gì thắc mắc đừng ngần ngại liên hệ với chúng tôi theo thông tin dưới đây để được hỗ trợ thêm.

Hẹn gặp lại các bạn trong các bài viết tiếp theo !

CÔNG TY CỔ PHẦN DỊCH VỤ CÔNG NGHỆ DATECH

• Địa chỉ: Số 23E4 KĐT Cầu Diễn, Tổ 7, Phú Diễn, Bắc Từ Liêm, Hà Nội

• Điện thoại: 02432012368

• Hotline: 098 115 6699

• Email: info@datech.vn

• Website: https://datech.vn