CÔNG TY CỔ PHẦN DỊCH VỤ CÔNG NGHỆ DATECH

Số 23E4 KĐT Cầu Diễn, Tổ 7, Phú Diễn, Bắc Từ Liêm, Hà Nội


Hướng dẫn quay số PPPoE trên Router Cisco

Hướng dẫn quay số PPPoE trên Router Cisco

Yêu cầu: sử dụng Router Cisco xác thực PPPoE, nhận IP cấp phát từ nhà mạng, các PC trong mạng LAN truy cập được Internet

Chuẩn Bị

  • Thông tin username/password của thuê bao được nhà mạng cung cấp (liên hệ nhà mạng hoặc xem trên hợp đồng)
  • Cắm Converter nếu hoặc cấu hình bridge trên modem của nhà mạng.
  • Xác định cổng WAN (như trên là G0/1) và LAN (G0/0), cắm dây mạng, đồng thời cấu hình Interface cho mạng LAN
  • Mỗi nhà mạng đều sẽ có đánh vlan tag cho cổng nên bạn cần phải set vlan cho cổng WAN, bạn có thể set vlan trong lúc bridge modem hoặc trên router cisco, vì mình muốn quản lý hoàn toàn trên router nên sẽ set trên router (để biết chính xác được nhà mạng mình đang gắn thuê bao của mình vào vlan nào các bạn có thể contact KTV khu vực hoặc gọi hotline, thường mạng Viettel là vlan 35 và VNPT là 11)

Tiến Hành Cấu Hình PPPoE Trên Router Cisco

  • Cấu hình Interface LAN

    interface GigabitEthernet0/0

    description LAN

    no shutdown

    ip nat inside

    ip address 192.168.1.1 255.255.255.0

  • Cấu hình Interface WAN

    interface GigabitEthernet0/2

    description WAN-VIETTEL

    no ip address

    no shut

  • Cấu hình subinterface trên cổng WAN theo vlan nhà mạng (ở đây mình dùng Viettel, vlan 35)

    interface GigabitEthernet0/2.35

    encapsulation dot1Q 35 pppoe enable (Cho phép PPPoE trên interface) pppoe-client dial-pool-number 1 (Gắn interface dialer)

  • Tạo Dialer Interface dùng để quay PPPoE

    interface Dialer 1

    ip address negotiated

    ( Lấy IP từ PPP )

    ip nat outside

    (gán interface NAT ra bên ngoài)

    encapsulation ppp

    (Đóng gói PPP)

    dialer pool 1

    (gắn Dialer interface này vào Dialer pool)

    ppp authentication pap callin

    (Chọn kiểu chứng thực PAP/CHAP)

    ppp pap sent-username password 0

    (thay / đã chuẩn bị để xác thực PPPoE

  • Cấu hình default route tới WAN

    ip route 0.0.0.0 0.0.0.0.0 Dialer 1

  • Tạo nat overload cho mạng LAN

    ip nat inside source list 1 interface Dialer1 overload

    access-list 100 permit ip any any

  • Nat cổng 80 của webserver 192.168.1.10 ra ngoài ip public thành cổng 8080 (tuỳ chọn)

         ip nat inside source static tcp 192.168.1.10 80 interface Dialer 1 8080

Chúc các bạn thực hiện thành công!

Nếu bạn có bất kỳ câu hỏi hoặc gặp khó khăn, đừng ngần ngại liên hệ với chúng tôi theo thông tin dưới đây để được hỗ trợ thêm.

CÔNG TY CỔ PHẦN DỊCH VỤ CÔNG NGHỆ DATECH

• Địa chỉ: Số 23E4 KĐT Cầu Diễn, Tổ 7, Phú Diễn, Bắc Từ Liêm, Hà Nội

• Điện thoại: 02432012368

• Hotline: 098 115 6699

 Email: info@datech.vn

• Website: https://datech.vn